F

Problem Formel Bemerkungen
Benutzerdefinierte Funktion

 

Wenn die Standardfunktionen von Excel nicht ausreichen, kann man über benutzerdefinierte Funktionen weitere Funktionalitäten erhalten.

Diese Funktionen werden in Excel wie Makros erstellt und bearbeitet.
Sie beginnen immer mit "Function xxxx()".

Hier gibt es dazu noch viel mehr Informationen und Beispiele

Feiertage berechnen =Feiertag(A1) siehe: Benutzerdefinierte Funktionen
alle Formeln anzeigen im Menü: Extras - Optionen - Allgemein
Das Kästchen "Formeln" aktivieren
Shortcut: Strg & #
Fehler in ellenlanger Formel suchen

Wer hat sich da noch nicht abgeplagt?

In der Bearbeitungsleiste einen kompletten Teilformelbereich markieren.

Jetzt die Taste F9 drücken und es erscheint das Teilformelergebnis.

Achtung:
Diese Testumwandlung müsst Ihr unbedingt mit der Escapetaste rückgängig machen, sonst bleibt das Teilformelergebnis statisch stehen. Im Beispiel würde immer "WAHR" stehen bleiben auch wenn "FALSCH" jetzt richtig wäre.

Formel einer bestimmten Zelle anzeigen =qFormel(A1) Benutzerdefinierte Funktion:

Function qFormel(c)
qFormel = Right(c.FormulaLocal, Len(c.FormulaLocal) - 1)
End Function

Fehlermeldung "#DIV/0!" ausschalten =WENN(ISTFEHLER(A1/B1;0;A1/B1)) Holzhammermethode, berechtigte Fehlermeldungen werden dadurch auch nicht mehr angezeigt.
=WENN(B1<>0;A1/B1;0) Sinnvoller, da die Ursache untersucht wird
Die Kopf- oder Fusszeilen-Texte werden nicht am definierten linken und rechten Rand (z.B. 1 cm) ausgerichtet Auszug aus der Onlinehilfe von Excel 97:
Kopf- und Fußzeilen werden nicht wie gewünscht ausgedruckt
.
Der rechte und linke Rand der Kopf- und Fußzeilen beträgt 2,0 cm und ist unabhängig vom rechten und linken Seitenrand.
.
Na ja, dann bleiben wohl nur noch Leertasten zur optischen Anpassung.
Firmenlogo in Kopf- oder Fußzeile Geht bis Excel 2000 absolut nicht. Für Excel XP (2002) ist es vorgesehen.

Eine Umgehungslösung ist nur für die Kopfzeile möglich:
Man nehme die obersten Zeilen von Excel als Wiederholungszeilen.
das geht so:
Unter dem Menü DATEI - SEITE EINRICHTEN auswählen.
Im Editor den Karteireiter TABELLE auswählen.

bestimmte Farbe in einem Bereich zählen =FARBEZÄHLEN(Bereich;Farbnummer)

=FARBEZÄHLEN(A1:E55;3)

Benutzerdefinierte Funktion:

Function FARBEZÄHLEN(Bereich As Range, Farbe As Byte)
Dim x As Long
For Each c In Bereich
    If c.Interior.ColorIndex = Farbe Then x = x + 1
    Next c
    FARBEZÄHLEN = x
End Function

Farbtabelle -- Siehe Extraseite


Meine aktuellsten Exceltipps finden Sie hier: